Saiba como filtrar e somar itens específicos em uma tabela no Excel

Em 10 ago 2015 - 2:15am por redação

A leitora Daiane entrou em contato com o Videobes Tecnologia perguntando como poderia fazer a soma de dados isolados de uma tabela automaticamente. De acordo com a internauta, a intenção dela era somar valores de vendas de produtos iguais, mas vendidos para clientes diferentes e em datas diversas.

Para fazer isso de forma automática, é preciso utilizar a função "Subtotal" do Excel aliada do recurso "Filtrar". Com elas será possível realizar as contas selecionando os tipos de dados de forma prática e rápida. Veja como:

Filtre e some itens específicos em uma tabela
  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    1.

    A primeira coisa a fazer é criar uma tabela e preenche-la de acordo com os dados que possui. No exemplo, o Videobes Tecnologia utilizou uma planilha de vendas de uma lanchonete fictícia Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    2.

    Depois de pronta, crie mais dois campos e intitule-os de Subtotal e Total Geral para facilitar a identificação futura Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    3.

    Agora selecione os itens da tabela, inclusive os campos que os caracterizam. No exemplo, esses campos são: Data, Produto e Preço Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    4.

    Com os dados selecionados, clique na guia "Dados" e escolha opção "Filtrar" Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    5.

    Se fizer corretamente, os campos descritivos irão contar com um pequeno botão que será usado para fazer a filtragem das informações Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    6.

    Volte às células que criou no Passo 2 deste tutorial e ao lado de Subtotal utilize a seguinte fórmula: =SUBTOTAL(9;célula com o primeiro preço:célula com o último preço). No exemplo, ficou assim: =SUBTOTAL(9;C4:C16) Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    7.

    Já ao lado da célula Total Geral insira a fórmula: =SOMA(célula com o primeiro preço:célula com o último preço).Como no exemplo: =SOMA(C4:C16) Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    8.

    Para classificar os valores obtidos pelas duas fórmulas como números monetários selecione-os e, na guia "Início", clique no campo de seleção que provavelmente vai estar com a inscrição "Geral" escolha a opção "Moeda" Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    9.

    Com a tabela pronta, selecione os dados que deseja filtrar clicando em algum dos botões inseridos campos descritos (no exemplo, Data, Produto e Preço). No caso, o exemplo deseja obter os resultados das vendas obtidas com Lanches e Refrigerantes Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    10.

    Observe que ao fazer o isso, o subtotal automaticamente é alterado, mas o total geral permanece igual, pois está configurado para calcular todos os campos inseridos Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    11.

    Se quiser filtrar os dados pela Data também é possível, basta repetir o processo Foto: Reprodução

  • Saiba como filtrar e somar itens específicos em uma tabela no Excel

    12.

    Pronto, desta forma você obtém resultados apenas dos campos que deseja somar. Aqui (http://Videobes.com/bkfZ9B), você pode baixar a tabela pronta. Foto: Reprodução

Saiba como filtrar e somar itens específicos em uma tabela no Excel

Comentários no Facebook